Текущее время: Ср, июн 28 2017, 19:38

Часовой пояс: UTC + 4 часа


Правила форума


ВНИМАНИЕ! Прежде чем задавать вопрос, ознакомьтесь со ссылками ниже:

Вопросы по отличиям версий SAP, Add-On, EHP - сюда
Вопросы по SAP Front End (SAPlogon, SAPgui, guiXT и т.д.) - сюда
Вопросы по LSMW - сюда
Вопросы по архивации в SAP - сюда
Вопросы по SAP GRC - сюда
Вопросы по SAP Business Workplace (почте SAP) и SAP Office - сюда
Вопросы по miniSAP (SAP mini basis) - сюда
Вопросы по SAP HANA - сюда
Вопросы по лицензированию продуктов SAP - сюда



Начать новую тему Ответить на тему  [ Сообщений: 2 ] 
Автор Сообщение
 Заголовок сообщения: SAP WEBGUI
СообщениеДобавлено: Вт, дек 20 2016, 13:25 
Менеджер
Менеджер
Аватара пользователя

Зарегистрирован:
Пн, янв 14 2013, 11:37
Сообщения: 671
Пол: Мужской
Доброго дня! Может кто-то сталкивался, на DEV и PRD системах /sap/bc/gui/sap/its/webgui через IE 11 открывается пустая белая страница, на QAS - все ок. На всех этих системах в других браузерах - все ок.
Я уже и кэш шаблона в SITSPMON сбрасывал, и /nSIAC_PUBLISH_ALL_INTERNAL, и сервис декативировал/активировал, и систему перезагружал полностью, и &sap-accessibility=X пробовал.
Проблема на 2 системах и только на IE 11.

Если включить консоль в IE, вижу ошибку при загрузке на проблемных системах:

if (oSyncReq.status != 200) {
this.clearBatch();
throw "Request failed: " + oSyncReq.statusText + " " + oSyncReq.status;
}
И ошибка: Исключение брошено и не поймано


Пометить тему как нерешенную
Вернуться к началу
 Профиль Отправить email  
 
 Заголовок сообщения: Re: SAP WEBGUI  Тема решена
СообщениеДобавлено: Вт, дек 20 2016, 15:42 
Менеджер
Менеджер
Аватара пользователя

Зарегистрирован:
Пн, янв 14 2013, 11:37
Сообщения: 671
Пол: Мужской
Разобрался. Ядро 7.22 PL 200. Выходит что оно вызывает устаревшую функцию XMLHttpRequest, на вызов которой хром забивает, а IE встает в раскоряку с не пойманным исключением.
"Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience."
Лечится ядром 7.22 PL 210. На QAS уже было обновление, лечил какую-то другую штуку, заодно и эта проблема ушла, вот поэтому и разница в поведении.


Пометить тему как нерешенную
Вернуться к началу
 Профиль Отправить email  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 2 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 6


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB